Raidbots Blog

Web Tools for WoW Nerds

Bugs

Known Limitations

  • World of Logs tools rely on their parsing of normal vs. heroic.  If they don’t yet identify a heroic fight, top DPS might be skewed until they do handle it properly.  Help them out by providing logs in their Bug Forum

Please leave any bug reports here!

73 responses to “Bugs

  1. Chira February 6, 2011 at 11:42 pm

    World of Logs changed the name of the encounter to the correctly spelled “Omnotron Defense System”, so the numbers are no longer being pulled correctly.

  2. Steve August 22, 2011 at 7:18 am

    Hey, I have a special character in my name – Vengeánce (a = alt+0225) and i definitely have WOL Parses, but cannot pull them up. Anyone else having this problem?

  3. Moshne September 1, 2011 at 12:18 am

    Elemental Shaman Greater Fire Elemental attacks are not being tracked on CompareBot. It tracks as damage of ours in WOL, would it be possible to add it?

    • seriallos September 1, 2011 at 12:29 am

      I’ll keep it in mind but pet tracking on CompareBot would be a decently large undertaking. Right now it can’t track any pets at all (true of all classes with permanent of temporary pets). It’s definitely possible but I have some other priorities on the site right now and I believe that World of Logs is considering revamping some of their site so I’m wary to make any large changes. CompareBot depends a lot of the actual layout of the page and so I’m waiting a bit to see more of what their up to before committing to anything but small bug fixes and additional spell tracking since those are really easy for me to implement.

  4. Icthelion Gilneas September 22, 2011 at 10:53 am

    When using Epeen Bot i notice that some of my logs from WOL for 9/20 are available (Shannox for example) but Baleroc and Alysrazor are not. ANy suggestions for fixing this. All fights are available in WOL.
    Thanks,

  5. Meloree September 28, 2011 at 10:15 am

    One of my Baleroc parses on epeenbot (http://raidbots.com/epeenbot/us/garona/meloree/) is listed as NaN, rather that a percentile. I am not entirely certain of what that means.

  6. seriallos September 28, 2011 at 6:56 pm

    NaN stands for “Not a Number” – it’s javascript’s way of saying that I did something wrong somewhere (usually caused when you divide by zero). I’ll take a look when I can.

  7. Moshne November 6, 2011 at 12:33 pm

    Epeenbot reports a different DPS value than both the DPS and DPS(e) value on World of Logs. It also has a different time for fight duration frequently (but this isn’t enough to account for the changing values.) How is it coming up with its DPS value?

    • seriallos November 6, 2011 at 5:36 pm

      Can you provide some links?

      I’m just dividing damage done by duration of fight which _should_ be the same as WOL’s DPS(e). Could be some weirdness in the data they give me, though.

  8. meep January 4, 2012 at 12:38 pm

    I’ve was issues with the epeen bot. I get none of my latest reports if , , are all not capitalized (e.g. /us/illidan/dexter – I haven’t actually checked this person’s records, just giving an example of the format.) I did get a newer records if I capitalized my name (e.g. us/illidan/Dexter). More still if I capitalized ‘US’ (e.g. US/illidan/dexter.) I got the most using a combination (Us/illidan/Dexter.) It seemed weird that the system was doing this.

    • meep January 4, 2012 at 1:45 pm

      As an update, the most accurate one turned out to be having the first character (and only the first,) of each part capitalized. Any other way caused logs to be missed. This is not the default format when searching a character on the bot.

      • seriallos January 6, 2012 at 8:39 pm

        Could you email me some specific links of the character you’re having problems with? It’s definitely possible that something is broken in the code that tries to normalize character and realm names (basically, unicode handling is always a pain in the ass and I didn’t do it correctly initially).

        Email is sollaires@gmail.com

  9. kodefoo March 30, 2012 at 12:30 pm

    There is a bug with my character on the attempts and percentages under the graph on the madness fight. The graph has been updating but not the numbers section below it.

    Ravencrest-US
    Kodecaster

    • seriallos March 31, 2012 at 1:09 pm

      Bug when EpeenBot didn’t detect any given role in a fight (in this case, no traditional tank specs were used). Fixed the bug though it might be persist until tomorrow due to caching.

  10. Sarral June 22, 2012 at 11:44 am

    My run from last night is not showing up, even though the fights of my co-conspirators are. Both are copied below, not sure what may cause me to not show up when those who ran with me are/do.

    http://raidbots.com/epeenbot/us/zangarmarsh/sarral/ (me)
    http://raidbots.com/epeenbot/us/zangarmarsh/norathar/ (co-conspirator)

    • seriallos June 23, 2012 at 12:21 am

      I see parses for you from 6/22 – your browser likely just has yesterday’s version cached (I have raidbots do pretty aggressive caching even on the client). Force refresh the page (ctrl-F5 on windows) or clear your browser cache and you should see your data. Worst case, it should show up within 24 hours.

  11. pnutbutter June 28, 2012 at 4:25 pm

    CompareBot reads the total damage weird for the latest report I did. The Damage tab shows the correct totals (without pets), but in the summary at the top of the report, the totals for DPS and Total Damage are inconsistent between characters. It excludes pet damage for character #1, but it includes pet damage for character #2. (Pet = Tentacle of the Old Ones for both characters)
    raidbots.com/comparebot/4fecb9f04b1cfbb7750001f0

  12. Drezzy September 12, 2012 at 12:23 am

    When trying to use Epeen Bot the auto complete for my realm when sent here via openraid is showing as Blades Edge and not Blade’s Edge which in turn mean it is unable to return any data and showing character as not found. Would it be possible for you to fix this please? http://raidbots.com/epeenbot/eu/blades%20edge/drezzy

    • seriallos September 22, 2012 at 1:26 pm

      This needs to be fixed on their side, unfortunately. The realm names don’t quite match up between raidbots and openraid because I use World of Logs realm name convention and openraid is using Blizzard’s convention. This isn’t something I can fix easily so I’m not currently planning on resolving the issue. Sorry it’s not quite working as easily as hoped!

  13. Mordekaiser November 12, 2012 at 9:17 pm

    I’m getting an issue with epeenbot where only some of my logs from this tier are showing. Its really quite confusing as some are showing up while others have gone completely missed. I can not see the pattern between those that are showing and those that are not. My character is Mordekaiser @ Khaz’goroth (US).

  14. Thargorn November 23, 2012 at 4:14 pm

    WoL updated their definitions for the Protectors of the Endless encounter in Terrace of the Endless Spring. When you kill the boss named Protector Kaolan last out of the three available, it gets flagged as “Hard mode” (Elite) and seemingly doesn’t show up on Epeen Bot.

    I can only use myself as an example, but out of our two boss kills, only the first one shows up on my Epeen bot and that was from before WoL added their hard mode definitions of the encounter.

    http://raidbots.com/epeenbot/eu/silvermoon/thargorn/

    Example log with the encounter not showing up on Epeen Bot: http://worldoflogs.com/reports/rt-qtzxkxblav1jzobe/dashboard/?s=9032&e=9517

    • seriallos November 24, 2012 at 7:35 pm

      It looks like WOL originally used the boss name “Protector of the Endless” – note the singular. It’s now showing up as the plural “Protectors”. Digging through the data, I see both parses but under different boss names (one as the singular, one as the plural).

      I’m running some scripts that should fix all the data up. May take a bit and won’t show up until tomorrow.

    • seriallos February 12, 2013 at 1:19 pm

      Two possibilities:

      – make sure you are looking at EDPS, not DPS
      – on comparebot, hunters are tracked by their personal DPS excluding pet damage. Pet damage should be included in dpsbot and epeenbot. This is a known limitation with the site and is not trivial to solve

      • thinpancakes February 12, 2013 at 9:00 pm

        lol i dont know all these terms i recently started coming to this website.. do you mean go to compare bot and type in my parses??

        • thinpancakes February 12, 2013 at 9:10 pm

          but part of the reason is because i have a pet i take it?? this is not a big deal to me i am just wondering ^-^, but those are the only bosses that i am under 50% on and its just weird to me that the other bosses from logs are the same on here but just not those 2 lol.. and like i said i am not trying to be rude just asking, and thank you for your time.

  15. Sigarda February 14, 2013 at 11:43 am

    Sometimes when I try to look up my character in epeen bot, my character sometimes doesnt show, pretty inconsistent in showing the page of my character. It will tell me “No data found for that character!”. My character is Sigarda from US-Jubei’thos

  16. Llamasham February 24, 2013 at 2:39 am

    Area 52 – Llamasham

    Not showing up as having any logs on epeenbot. Report was submitted 4 hours ago?

    • seriallos February 24, 2013 at 1:42 pm

      Logs for today won’t show up until tomorrow. I get a daily export from WOL at roughly 9AM EST and those reports should be finished processing by roughly 2PM EST.

  17. Alex March 8, 2013 at 11:48 pm

    Horridon doesn’t seem to work in EpeenBot, probably because the JSON it returns is always empty. Ex: http://raidbots.com/json/ebcd/Horridon/25N/1101

  18. Moshne March 11, 2013 at 1:34 am

    CompareBot is not tracking glyphed Divine Plea

  19. jon May 10, 2013 at 10:15 pm

    Epeenbot aint working with realm EU-Aggra (português), ive tried several chars with logs on WoL and Epeenbot always says that no data was found for any char. Can you fix this please?

  20. Moshne June 17, 2013 at 9:53 am

    A number of abilities are missing in the CompareBot “Significant Abilities”:

    – Astral Shift for Shaman (level 15 talent shared with Stone Bulwark Totem)
    – Anything for Monks
    – Ascendance for Shaman

    I’ll ask my guild to look at each class and see if I can get a complete list.

  21. Tinypaws July 27, 2013 at 11:04 pm

    My character is not being found on it’s current server by raidbots epeen bot. I have active public logs on this server and have been on the server for over a month. Why is this happening?

    • seriallos July 28, 2013 at 12:18 am

      Most common issue is that your parses on WOL are listed on a different realm than where you actually are. Go to your guild page and check the realm in the upper left. If its correct, post a link to WOL or send me an email and ill check it out

  22. Kipp August 2, 2013 at 1:25 am

    Could not pull my toon up.
    Realm / Grizzly Hills
    Toon / Elektrode
    WOL / http://www.worldoflogs.com/guilds/267219/

  23. Austin September 5, 2013 at 12:18 am

    Could not pull my toon up on Epeen
    Realm – Mal’Ganis ( US)
    Toon – Styyle
    WoL – http://www.worldoflogs.com/reports/rt-zfj3d4gxq440tpk6/

  24. rynedelewis November 3, 2013 at 2:28 pm

    Been checking raidbots all day to see what percentils i ranked in last night. and they are not showing up. They are uploaded to WoL. I live log so there shouldnt be anything blocking your upload.

  25. Rhynno November 4, 2013 at 5:56 pm

    So the team I logged with has been uploaded to a different raid team. I raided on Kel’Thuzud but the logs I uploaded too are on Whisperwind. I think that might be causing an issue with the upload. Please let me know if it is. I think my file might be too big to upload manually. I will try. If this is the case is there any hope to this fix?

  26. Fildrance November 7, 2013 at 1:59 pm

    Direct link on epeenbot always works for ru realms/character (like “http://raidbots.com/epeenbot/eu/ясеневый лес/филдранс”) but when i try to use part of this for json feed (like “http://raidbots.com/json/playerdata/eu/ясеневый лес/филдранс”) it returns empty data, like none was found. Please, look at this : (

    • rynedelewis November 9, 2013 at 11:54 am

      If by chance it was a flex/cross realm stuff, or the “logger” uploaded it through a different realm. You’ll have to search it under that realm and your characters name. EX. US-Kel’THuzud-Rynedelewis has logs for certain fights. Those are fights my raid leader logged. I can search US-Whisperwind-Rynedelewis and find some of the same fights that we both logged due to me uploading them into my Paladins guild on Whisperwind.Oh btw raidbots moderater. I posted twice about this and I figured it out on my own. You can try that let me know if it works.

      • Fildrance November 10, 2013 at 12:06 am

        That’s a pity but all logs with that char are not cross-realmed.
        So i guess your solution won’t work. But nice tip though, thanks! : )

    • seriallos November 29, 2013 at 1:55 pm

      This has been fixed. Minor bug in handling UTF8 realm/characters in the JSON code. Should be fully working some time after the cache clear today or tomorrow.

  27. Wigrafzrolok November 15, 2013 at 12:12 pm

    So, we logged a raid last night and only the first five of the eight bosses we killed are showing up on Epeenbot: http://worldoflogs.com/reports/rt-h45jzow4jvf39a81/dashboard/ , http://raidbots.com/epeenbot/us/kul%20tiras/wigrafzrolok/

    I can’t recall seeing something like this happening before … is there a way to get those other bosses from that log on there ?

  28. rynedelewis November 29, 2013 at 5:07 pm

    If you raided with a different team on a realm different than your current realm. Your logs still exist on this site. For instance, if you’re from KT and raided with WW team. Then, under Epeen Bot, your toon will be found under WW Name. EX Your toon- US-Kel’thuzad-Wigrafzrolok can be found under US-Whisperwind-Wigrafzrolok

  29. Gildartsa January 8, 2014 at 11:24 am

    Did a clear up to thok last night on heroic, all of it was logged.
    Looked on my epeen this morning and it only had protectors and norushen.
    Gildartsa US-Stormreaver
    (Healing parses – Current Tier)

  30. Tyler January 24, 2014 at 1:31 am

    The website Warcraft Logs is not showing up on this website. Is there any way you could add the records on that server?

  31. Magicz April 27, 2014 at 2:33 am

    Magicz-US Proudmoore, my toon isnt showing up here, I recently transferred so this may be the reason.

  32. Magicz May 4, 2014 at 6:19 pm

    Another thing. Magicz-US Proudmoore is still not showing up. recently transferred and was logged on proudmoore as well. Any reason its not showing up?

  33. maryjane May 24, 2014 at 6:03 am

    Not a bug, but a question.
    Ive been raiding XRealm the other day. Does Epeenbot also track world of logs data in which i show up, if it isnt my hometown realm?

  34. Mortis July 7, 2014 at 9:48 pm

    Character is Mortis on US-Suramar. I have old logs from Suramar, but am looking for the most recent ones when I was running with a group from US-Blackrock (Pokemon Masters) . It’s not pulling anything and not sure how to fix it.

  35. Hellsgeneral July 15, 2014 at 6:38 pm

    Cannot find character Yahmosa=Black Dragonflight using DPSbot

  36. Jannick September 16, 2014 at 12:57 pm

    Hello i have raided 10m heroic for quite some time now but it only shows 25m normal and 10m normal… also it says im on Aszune-EU when im on brinzebeard server :/ can someone pls help me find the logs for heroic ?

  37. Ed November 12, 2014 at 1:00 am

    My character isn’t showing up. I transferred him a while ago. Just did SoO several times and am not seeing any data. Thanks!
    Name: Zonny
    Server: US-Stormrage

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.